Results 1 to 5 of 5


  1. #1


    2000 W reg, 3 litre, 54450 miles at time of writing, new MOT, 5 months tax, fully loaded and everything works, Goodrich all terrain tyres, all oils and cambelt/waterpump changed within the last 2000 miles, starts and runs faultlessly, the 4x4 engage light flashes on and off but does not affect the motor in any way, I had this checked out recently by a specialist auto electrical company and they could not find a fault, 2000 location West Sussex.
    Attached Thumbnails Attached Thumbnails SHOGUN4.jpg   SHOGUN3.jpg   SHOGUN2.jpg   SHOGUN1.jpg  

  2. #2
    Maybe light flashing coz not used diff lock much and got crud in it . Try reversing a bit then see what happens . Plenty of on line help re this issue.

    ​what mpg do you get??

  3. #3
    Thanks for the advice, I have tried all of the online tips to no avail. it doesn't affect the motor at all so I put a piece of black tape over the flicking logo, I'm not to heavy footed so I'm getting low 20's to the gallon.

  4. #4
    i take it this is petrol?.looks really nice..

  5. #5

Similar Threads

  1. Wanted shogun sport cambelt kit
    By bangabunny in forum Vehicles
    Replies: 1
    Last Post: 22-11-2012, 12:20
  2. Limited Mileage 4x4 registrations
    By Labrat in forum Deer Stalking General
    Replies: 4
    Last Post: 28-03-2012, 16:10
  3. For Sale Low Mileage 2005 BMW R1200GS Yellow FSH
    By TASR12 in forum Vehicles
    Replies: 0
    Last Post: 06-11-2011, 10:32
  4. Mitsubishi Shogun Sport
    By deaf dog in forum Deer Stalking General
    Replies: 14
    Last Post: 18-05-2011, 15:09
  5. Wanted Tikka Optilock - blued bases and extra low or low rings
    By Leupsak in forum Deer Stalking Equipment
    Replies: 1
    Last Post: 01-06-2010, 14:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts