Results 1 to 10 of 10

Thread: Any computer boffs on?

  1. #1

    Any computer boffs on?

    I have been having problems with firefox recently in that on some pages it will not open a link in a new tab or the current tab.

    An example is the petplan website which I have just tried to use to get an insurance quote for my dog.

    The page the link is on is:

    and it's the get quote button.

    When I click it, nothing happens and if I try holding CTRL and pressing the link, a new tab opens with javascript:go(); in the address bar.

    It is the same with the guntrader website if I try and open a photograph of a gun.

    Any ideas much appreciated



  2. #2
    Which version of Firefox are you running and have you enabled Javascript?

    I'm running version 3.0 with javascript enabled and it appears to work...

    Looking at the page, the get quote button is actually a link, except that the link address is actually a line of javascript which is supposed to then open up a different window depending on which animal you've picked. What's happening for you is that the javascript is not executing, it's actually just trying to open the link as is.

    I'm not a javascript expert, but I'm guessing that this is a hack that works in IE, but not in older versions of Firefox and a later version may handle this hack 'correctly'... AFAIK you're not supposed to have executable javascript where a link is supposed to be, there should be a 'proper' way of doing it.

  3. #3
    Links are good for me here, I'm on the Firefox (automatically updated versions), Steve.

  4. #4
    its version 3.5.7. and it appears that javascript is enabled.

  5. #5
    If you have explorer installed you could try using that instead!

    I had a similar problem, but the other way round - it wouldn't open in Explorer so I switched to FireFox and ... hey presto! worked first time!

    Computer says no! ....... cough

  6. #6
    updating your browser should work but first clear out your temp files, cookies etc because left over temps can mess with settings which is quicker that updating!

  7. #7
    Are you running any 3rd party addons or popup blockers? Try running Firefox in safe mode and see if it works...

  8. #8
    I'm using Firefox 3.5.6 (under Ubuntu (Linux!)) and it works fine.


  9. #9
    hi....yes my thoughs are the pop up blocker may be stopping it, go into tools/options/content and untick the block popups tab...restart and enter the address you have and see if it works. if it does add it to the allow site part of the popup options....hope that makes sense...


  10. #10
    SD Regular
    Join Date
    Dec 2008
    East Midlands M1/M69 Junction 21
    I'm using Windows 98SE and Mozilla 5.0 Firefox and can access it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts