Anyone got a Swarovski X5i?

Czhowa

Well-Known Member
Just wondering if anyone has a Swarovski X5i? I'm having an issue with the illuminated Ret and Swarovski themselves haven't been very helpful so far. Maybe their point was lost in translation 🤔
Cheers
 

the scudd

Well-Known Member
I had a problem with the illumination on my old z4i
Even though it was out of warranty they sorted it out free of charge
 

Czhowa

Well-Known Member
Mine is a dimly illuminated dot but the inner tube is lit up. Impossible to see through at night. Was yours similar?
 

Gm81

Well-Known Member
Mine is a dimly illuminated dot but the inner tube is lit up. Impossible to see through at night. Was yours similar?
If my head isn't exactly behind the scope you can catch the sides of the tube lit up on my x5i.
Only thing that is bad about it. I looked through a z6i in a shop and that was the same.
If swarovski got the illumination like my zeiss they would have it to perfection.
 

Czhowa

Well-Known Member
My mate has an older Swarovski (not sure of the model) and the dot is bright and crisp with hardly any light on the tube.
Mine however is like a traffic light!
 

Attachments

  • IMG_20210617_183250__01.jpg
    IMG_20210617_183250__01.jpg
    172.6 KB · Views: 19

andy R204

Well-Known Member
Have one on the 6mmBR..plex with the illuminated dot.Never seen anything like in your piccy.
Have you tried adjusting the ocular lens to see if anything changes?
 

Czhowa

Well-Known Member
No but I've piled a towel in front of the lens.
The athlon Midas that the Swarovski replaced had barely any tube reflection, even an old hawke is better 😂.
Yeah tried everything that the scope can do. Oddly that is full power for the illumination (10)..
If I back down the power settings to 6 the dot is barely visible, any lower and you can't see it.
Something is fooked and for a 2.5k scope I'm very disappointed.
 

samdk

Well-Known Member
I have an X5i and mine is showing no tire reflection at all, even at fully power! Is it new?

Get in touch with Swarovski, they should help!

Sam
 

Czhowa

Well-Known Member
Yep, well 6 months old. I'd not had it out in the dark until a couple of weeks ago so I wasn't aware of the problem
 

Tazz

Well-Known Member
Try turning the illumination right up to max then right down to virtually nothing then reset it
 

Gm81

Well-Known Member
This is mine. First one camera close to scope and on max brightness with my hand over it. So you would never use it like that. But it shows the only flaw with it compared to zeiss.
Second is where your eye would be and as long as I am constant in my head position I don't notice it really
 

Attachments

  • IMG_20210620_185923.jpg
    IMG_20210620_185923.jpg
    98.4 KB · Views: 6
  • IMG_20210620_185931.jpg
    IMG_20210620_185931.jpg
    82.9 KB · Views: 6

Czhowa

Well-Known Member
Full power against light background.
50% power, no dot visible.
If this is what to expect from Swarovski then I'm shocked. Gonna finish my ladder test of some new nosler lead free this week then it's coming off my rifle and going back from whence it came. I'll chuck my rimfires vortex on my howa and make do for a couple of months 👍
 

Gm81

Well-Known Member
I think it's the only thing that let's a swarovski scope down. But it's does everything else so well. Plus I feel the illumination isn't really what this scope is about. I don't shoot long range in the dark. So when I am using the feature I feel the scope is that good it will compete at last light. I also find the crosshairs and clarity great for shooting muntjac.
 

Gm81

Well-Known Member
Full power against light background.
50% power, no dot visible.
If this is what to expect from Swarovski then I'm shocked. Gonna finish my ladder test of some new nosler lead free this week then it's coming off my rifle and going back from whence it came. I'll chuck my rimfires vortex on my howa and make do for a couple of months 👍
You should be really happy with this scope. For me it's a 9/10. If it was a zeiss style illumination it would be a 10/10. But I guess this depends on your use.
Have you sent the images to swarovski if you can?
 

Czhowa

Well-Known Member
My mates Swarovski (can't remember the model). Visible in daylight, razor sharp (if the camera was in focus) and no light ring. This is what I was expecting from a 2.5k unit. I'll let you know what they say and if they can fix it 👍
IMG-20210527-WA0000.jpg
 
Top