Zeiss Victory Zeroing Problem

davidfm

Well-Known Member
I have after much saving purchased a Zeiss Victory Diavari scope with BDC. I have fitted it to a Blaser saddlemount with 30 mm rings. However I am having problems zeroing it. Even at the limit of lowest adjustment it is still shooting 50mm high at 25 metres. Previously I had a Schmidt & Bender 3-12 x 50 fitted to the saddlemount and had no such issues.

Does anyone have any ideas what the problem may be and how to address it? Your suggestions would be appreciated.
 

Hornet 6

Well-Known Member
Double check the scope mounting, if that mount has worked before on that barrel then unless the scope is defective
it has to be the way it is mounted.
(screws all evenly tight, same ring the base gap each side, scope to far back to sit right in the rings etc.)

Neil. :)
 

fizzbangwhallop

Well-Known Member
Certainly very unusual for a BDC Diavari not to work in a Saddlemount. :-|

What size 'scope are you struggling with? I've got 5mm click 6-24's on my barrels including a 10mm click Hubble x72 on a Match barrel... I also had a 4-16x50 on a .243 barrel and that zeroed ok too.... although having just tried it on a .17Rem Tikka 595 I did notice I was near the end of the vertical travel to get it bore-sighted.

Going down a Pic rail route is an expensive and unnecessary solution and the under turret bulge (bulk!) of the Zeiss will force you to higher rings than usual.... unless you grind a bit off the centre of the rail. Been there, tried that - the pic rail from zruncho on fleabay is a nicely made bit of kit though. Lowest solution I found.

It's possible that the 'scope is a duff one....(My gut feeling) Anyone close to you with the same 'scope in a Saddlemount to cross-compare?

Fantastic 'scopes though and well worth persevering with.

Cheers

Fizz
:cool:
 

davidfm

Well-Known Member
Thanks Fizz for your advice. It is a 4-16 x 50 Diavari. I thought I might contact Zeiss technical support for their opinion before doing anything else. My friend has the same scope but his is mounted on a Sako 75 with no issues.

David
 

6mmHOT

Well-Known Member
Hello mate

Mate

You are mounting your scope too far back

There is a very slight bump in the last few mm of the zeiss rail

This will effectively raise your scope with a tilt and thats exactly whats happening

Move your scope forward every so slightly and you will be fine

ATB
 

jb7x57

Well-Known Member
The victory has very little elevation adjustment. Only 2 turns most other scopes have 3 to 4 turns if my memory is working properly
 

fizzbangwhallop

Well-Known Member
I zeroed one today no problems, are you taking the top turret to bits to go past the zero stop?

Good point Gary..... forgot about that bit!

Even though it caught me out a fortnight ago so I had to go back to it and just check it. Then I got my Z6i 2.5-15x56 back from the factory and that went on the Tikka.....
 
Last edited:

davidfm

Well-Known Member
Yes I have taken the top turret off and used the tappet but have reached the lowest adjustment stop.
 

RPA 6MM BR

Well-Known Member
I have experienced this in the past, its well worth trying the following due to slight manufacturing differences. Just unscrew the two rings from the saddle mount and swap the front one for the back, I think you will find you are fine ;)
 
Top