Peltor ear defenders problem?

Dawnrazor

Well-Known Member
My Peltor Sport Tac ear defenders have just stopped working, I've changed the batteries but this hasn't sorted them? Has anyone had the same problems? Is there an easy fix? Can you send them to be fixed? Thanks.
 

Milligan

Well-Known Member
never known anyone to have trouble. Perhaps contact 3m direct? 0870 60 800 60 (United Kingdom)
stupid question but the batteries are in the right way round, right?
 

slider

Well-Known Member
Iv'e had trouble with 2 sets - both draining batteries.

First set went wrong at about 3 months old and after being used in heavy rain - had them in a warm cupboard for 4 weeks but no improvement. 3m replaced no questions asked.

Replacement set did the same so I just take a battery out after ever use
 

oxfordshirestalker

Well-Known Member
I love mine but they've started hissing at me, as though the connections have got wet. I've tried drying them out, changing the batteries again but no luck!
No problems with them just stopping working though, that sounds a bit fishy.
 

Glyn 1

Well-Known Member
My first pair were brilliant, lasted years, second pair were nothing but trouble, eventually managed to get them replaced, next pair never worked properly either. Gave up on them as I was losing the will to live with the supplier. Now they are just a very expensive pair of spare passive ear defenders. Bought the MSN Sordins, very happy now.
 

Dawnrazor

Well-Known Member
I love mine but they've started hissing at me, as though the connections have got wet. I've tried drying them out, changing the batteries again but no luck!
No problems with them just stopping working though, that sounds a bit fishy.
They're about 5 years old, worked perfectly untill this morning, loading for the boss, put them on at the first drive, nothing, thought the batteries were flat, changed them for a new set when I got home tonight, nothing!!! A bit gutted as I really like them and don't fancy shelling out for a new pair.
 

Dawnrazor

Well-Known Member
Got the Pelton ear defenders back from 3M today, replaced the chip board, new foam inserts, new green outer plastic covers and new padded........... What ever the soft padded bits that go round your ears are called!!! 60 quid, great service.
 

SilverJonten

New Member
I have had the same with my Sport Tac bluetooth.
the problem was the metal that connects to the battery's ends.
take a small screwdriver and bend them up a little against the battery, that solved my problem.
it seems that the metal was not in contact tomthe + and - poles after a while. Poor construction!
 

Druid

Well-Known Member
Mine are about 15 year old so probably different to the current model. No probs apart from losing the foam bits off the microphones. Can't really blame the manufacturer for that though
 

Top